The access issues affecting Risk Manager, Policy Manager, User Access Review, and Trust Center have been fully resolved. Following the deployment of a fix and a period of monitoring, we have confirmed that all affected components are performing as expected. No further issues have been observed.
Posted May 08, 2025 - 06:59 UTC
Monitoring
We have identified the root cause of the access issues affecting some users across components including Risk Manager, Policy Manager, User Access Review, and Trust Center. A fix has been deployed, and access to these resources should now be functioning as expected.
We are currently monitoring the platform to ensure that the issue has been fully resolved and performance remains stable.
Posted May 07, 2025 - 19:57 UTC
Update
We are continuing to investigate this issue.
Posted May 07, 2025 - 17:55 UTC
Investigating
We are currently investigating an issue where some users are intermittently unable to access certain resources within our platform. This behavior is affecting access to several key components, including: * Risk Manager - reviewers might fail to review * Policy Manager - reviewers might fail to review * User Access Review - reviewers might fail to review * Trust Center - approval flows might fail, and external users won't have access to the resources
Impact:
Access to the above components may fail or result in errors for some users, mainly external stakeholders, under certain conditions. The issue appears to be inconsistent, affecting only a subset of sessions or accounts.
Posted May 07, 2025 - 17:53 UTC
This incident affected: Applications (Policy Manager, Risks Manager, User Access Review, Trust Center).